EVE Central Spreadsheet Integration: Gone Wrong?

Forum rules
This forum can be viewed by the public.
<<

E Fyre

Portrait

Member
Member

Post 2016.06.02 05:59

EVE Central Spreadsheet Integration: Gone Wrong?

Hello everyone!

About 24 hours ago, I managed to create some URL's linking my manufacturing spreadsheets to EVE Central's market data. Hit some setbacks along the way (turns out Excel won't take URL's beyond 250-something characters so I had to cut it down to about 12 separate URL's to create 12 different tables. Minor inconvenience, since I'm tracking basically all PI/Moon Goo/Ore/Ice materials). This was great, I managed to refresh them all a few times last night and everything was working wonderfully.

That is until tonight. When I hit the "Refresh" button, suddenly, Excel lets me know that there was an error with 4 or so of the URL's. I get hit with a,

"The following data range failed to refresh: evec_api_Map. Continue to refresh all?"


Naturally, I hit that OK button and hope for the best. A few seconds later another popup window,

"XML Import Error. Microsoft Excel encountered errors when importing the following files [Imagine Source URL here] Error: Data source not found"


And this sequence happens for 4 of my dozen or so URL's. For their corresponding tables, the numbers do not change. Simply not updated. Even more unnerving is the fact that, for about 3 of the URL's that did return and get refreshed, the last row (market item) returned nothing, not even the typeid written in the URL. Just a blank row on the table.

Naturally, I'm a bit perplexed as to why this would happen if just 24 hours ago, they were working brilliantly. I checked the URL's I used for those 4 sources Excel claims do not exist, using my browser, and they do in fact display the data from EVE Central.

Any input as to what I might be doing wrong or should go back and fix would be greatly appreciated. I was super excited about creating and testing this last night with much success, only to be profoundly disappointed tonight with these error messages.
Last edited by E Fyre on 2016.06.04 04:32, edited 1 time in total.
ImageImageImageImageImage
Image
<<

E Fyre

Portrait

Member
Member

Post 2016.06.04 04:16

Re: EVE Central Spreadsheet Integration: Gone Wrong?

Update

Having changed nothing nor touching the URL's, now none of them work--they all result in those error messages from earlier. In fact, copy/pasting the URL's into a browser now results in "502 Bad Gateway".

ex:
http://api.eve-central.com/api/marketstat?typeid=2073&typeid=2288&typeid=2286&typeid=2306&typeid=2309&typeid=2305&typeid=2311&typeid=2310&typeid=2308&typeid=2270&typeid=2287&typeid=2267&typeid=2307&typeid=2272&typeid=2268&typeid=2393&usesystem=30000142

These are the url's in their original form, the same ones that worked flawlessly a few days ago.

Any and all input would be appreciated :(
ImageImageImageImageImage
Image
<<

Stringfellow Hauk

Portrait

Member
Member

Post 2016.06.04 04:34

Re: EVE Central Spreadsheet Integration: Gone Wrong?

It might be a problem at Eve Central. I've noticed that the API behavior has been acting a little flakey over the last couple of days. Their own website didn't update pricing data for almost 15 hours earlier in the week. And my Google Docs spreadsheet that uses a script to pull PI pricing data doesn't seem to be working either. I also tried typing a manual URL that I know worked a couple of days ago and it's not functioning.

I suspect that it'll just magically begin working again sometime in the next couple of days. Or not. I've been less than impressed with the consistency of Eve Central's APIs. But they always seem to eventually start working again.
<<

E Fyre

Portrait

Member
Member

Post 2016.06.04 05:23

Re: EVE Central Spreadsheet Integration: Gone Wrong?

I hope you're right, as it would explain the gradual decline into total failure from my API's. *fingers crossed*
ImageImageImageImageImage
Image
<<

Melkor Gengod

Portrait

Member
Member

Post 2016.06.04 09:15

Re: EVE Central Spreadsheet Integration: Gone Wrong?

There is a common problem with the eve central API in Google docs which may be repeated in excel to do with the caching of the data. To get round it, eve central has an optional cachbuster option. I link it to a bright red cell on my sheet, and I have issues just type in a random number and it forces the sheet to resend the request.

......marketstat?cachebuster="&A1&"&typeid=34......

The syntax for concatenation of the cell A1 may differ in excel.
Image
<<

Stringfellow Hauk

Portrait

Member
Member

Post 2016.06.04 14:52

Re: EVE Central Spreadsheet Integration: Gone Wrong?

Yep. I have the CacheBuster function integrated into my spreadsheet. Still no joy for me. But losing access for a day or so doesn't seem to be unusual for me. That's why I also run a regularly updating snapshot page that my formulas default to when the Eve Central data won't pull. I'm not too worried about it yet. If it's still down tomorrow, then I'll start crawling the web looking for answers.
<<

Stringfellow Hauk

Portrait

Member
Member

Post 2016.06.04 20:27

Re: EVE Central Spreadsheet Integration: Gone Wrong?

So my spreadsheets are back up and they seem to be pulling normally from Eve Central again.
<<

E Fyre

Portrait

Member
Member

Post 2016.06.04 23:00

Re: EVE Central Spreadsheet Integration: Gone Wrong?

Most of mine are working again, except for 3 of the API's, which give me that same "No data source found" error as when the problems first started, and around 4 API's that return with last item missing... *sigh*

:?
ImageImageImageImageImage
Image
<<

Aren Dar

Portrait

Member
Member

Post 2016.06.05 12:31

Re: EVE Central Spreadsheet Integration: Gone Wrong?

E Fyre wrote:I hope you're right, as it would explain the gradual decline into total failure from my API's. *fingers crossed*


The API server was down yesterday for a long period of time, unless you had a separate local cache you were st the mercy of however the caching on your app was implemented.

Return to Research, Production and Trade

Who is online

Users browsing this forum: No registered users

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Powered by Dediserve